Crate Timestamp

#1

hi,

is there a way to force timestamps to be in seconds instead of milliseconds?
Our Framework and PHP use seconds instead of milliseconds.
This would make it way easier if I can force the timestamp to be in seconds.

Thanks in advance
J

#2

I worked around this by sending a Iso 8601 String

#3

Hi @julianmar,

Maybe using a generated column would also be a solution: https://crate.io/docs/crate/reference/en/latest/general/ddl/generated-columns.html

Best
Roman

#4

Other option might be SELECT date_trunc('second', ts) FROM ...