Node in read-only mode after low diskspace

#1

Hi,

The machine was using over 90% diskspace and the cratedb note went into read-only mode.
I deleted lots of files and the server has now over 30% of available space.
The cratedb node was restarted, everything is green in the admin console but it is still in read-only mode.

SQLActionException[ClusterBlockException: blocked by: [FORBIDDEN/12/index read-only / allow delete (api)];]

How can I enable writes again?

CrateDB version: 3.1.4

0 Likes

#2

You can enable writes by using ALTER TABLE ... SET ("blocks.read_only_allow_delete" = FALSE), see our allocation setting docs for more information.

0 Likes

#3

Thank you that worked!

It would be great if the node could detect that disk space is below the threshold again and automatically make the node writable, instead of having to manually update each table.

Cheers,
Olav

0 Likes